GIS II Exercise 3 – Perform Market Analysis & Site New Store (v3c, Dec 2008)

Objectives:
- Modify / use census tract database to determine under-18 age distribution in your county
- Build spreadsheet of street addresses of similar businesses in your county
- Geocode & map business locations using TIGER street data
- Propose a location for a new Toys B Me store in your county
- Create a buffer around location and determine number of potential customers < 18 yrs old

Scenario:
Your student marketing team has been asked by the NJ marketing manager for Toys B Me to determine the best place for a new store. Each store must have a good base of customers (school-age kids 5-18 years old), and you may not want to be too close to another toy store.

You can use the TIGER census tracts and demographics database you used for Exr 01, but you will have to create and add some new information to the GIS. You will need to create an external spreadsheet that contains the names and addresses of existing toy stores, including other toy stores in your study area, and then use geocoding to spatially link these addresses to a TIGER line features-roads theme for your county, thereby creating a new point shapefile that will show the locations of these stores.

You will first want to define your particular study area – it could be a city or a county. An entire county may be too large an area for you alone to study. This may not be due to a lack of GIS data to manipulate, but rather because of the need to determine the names and addresses of all the toy stores in the county, which could be a daunting task in densely populated northern New Jersey. Therefore, you may decide to network with your fellow students, determine who lives in your county, and then break the county up into study areas that each of you can evaluate, just like you might do in the marketing department of a major corporation.

Procedure

Step 1a - Bring the data into ArcMap
Open ArcMap, use Layer Properties to set the coordinate system to Geographic – North American Datum 1983 and add the TIGER data you used in Exr 01: census tract shapefiles for your county, the census tract SF-1 demographics data for your county, and the line features-roads for your county. Copy these files into an Exr03 folder you create for yourself inside your GIS II folder in order to facilitate data management. **NOTE:** Make sure that your coordinate systems are defined for the shapefiles (Geographic – North American Datum 1983). This will be important for accurate geocoding. Your map should look something like this:
**Step 1b – Use SF-1 Census Tract data to determine the target market**

From the ArcMap Table of Contents (ToC), right-click on your census tract shapefile > Joins and Relates > Join. Join the census tracts shapefiles to the SF-1 demographics .dbf database using STFID as the “primary key” (if asked to create an index, choose either yes or no):

From the ToC, right-click on the census tract shp > Open Attribute Table. Notice that there are two categories of children, “age_under5” and “age_5_17”, who would be good Toys B Me customers:

You will want to map the total number of children combined in these two categories in your county, but this requires modification of the demographics database and addition of a new column that contains the sum of these two categories. This task requires you to use ArcCatalog to edit this database. Before you can edit this table, remove the Join, save your .mxd, and close ArcMap.
Step 2 - Use ArcCatalog to add a new field to census tracts SF-1 database

Now you will open ArcCatalog. Browse to the SF-1 census tracts demographics database you saved in your file folder, and select the Preview tab in the RH window to open the database:

Select the Options button, and select the Add Field button in the drop-down menu that opens. An Add Field window opens, in which you will select a name for the new field. **IMPORTANT:** A number of AV functions follow an “8.3” DOS naming protocol requiring **no more than 8 characters for a name**; I used “under18” (see below). Concerning “type”, since you will be calculating some relatively small values by adding two columns, “age_under5” and “age_5_17”, together, the default type (Short Integer) should work fine for this exercise:

Now that you have created this new “under18” column, close Arc Catalog.
Step 3 - Use ArcMap in editing session to calculate values for the new field
You will now re-open your ArcMap .mxd project. In order to have maximum editing capability, you will want to start an editing session. Click on the Editor toolbar menu, select “Start Editing”:

Right-click the SF-1 demographics .dbf database in the ToC, right-click on the name, and select **Open** from the drop-down menu (make sure you have selected the **Source** tab in the ToC):
Select the “under18” field at the RH side of the table. Rt-click, select “Field Calculator”:

Click on Field Calculator and a window appears (below left):

Complete the expression started in the grey area (under18 =) by selecting age_under5 + age_5_17 from the available fields (above, right). Click OK, and AV will populate the field “under18” with the calculated values (below):

Once the calculation is complete, you must return to the Editor toolbar dropdown menu and select “Stop Editing”. When prompted to save your edits, click “Yes”. AV8 won’t let you move on to other operations until you finish your editing session.
Step 4 - Use the Table of Contents to display no. of children under 18 for each census tract

Open ArcMap and re-join your newly-edited SF-1 demographics database to the census tract shapefile attribute table (see earlier directions for help if necessary). Color-code your census tracts shapefile according to the number of school age children “under18” by rt-clicking on the census tracts shapefile in the ToC, scroll to Properties > Symbology > Quantities > Graduated Colors. Select an easy-to-understand color ramp that will intuitively show where all the children live!

Use the Classify button (black arrow, above left) to move to the second page, in which select the Method as Defined Interval and select some reasonable number for the interval based upon your data shown in the white window (I used 1000). There are other options, including normalizing the “under18” as a percent of total population, or normalizing it relative to the population in each tract.

Click OK, and your map returns with census tracts that are now color-coded according to the number of children that comprise your target market for your new toy store:
Step 5 - Find the toy stores in your study area and create an Input Address Table

Now you must find all the REAL toy stores in your study area. How do you do this? First, set up an Excel spreadsheet. Use the following column headers:

<table>
<thead>
<tr>
<th>Name</th>
<th>Street_Address</th>
<th>City</th>
<th>State</th>
<th>Zipcode</th>
</tr>
</thead>
</table>

**Note:** it is VERY important that you re-format the “Zipcode” column in MS Excel as text BEFORE you enter the 5-digit zipcode in order to preserve all 5 digits of your zipcodes. Excel has a tendency to drop the zero in front of many zipcodes, even when this column is formatted as “zipcode”(!). 4-digit zipcodes may not be recognized when geocoding. Once you have set up the Address Table, save it as yourcounty_toy_stores (or yourname_toy_stores).

Now you need to find data. Yahoo Yellow Pages is a good place to start. Remember to get zipcode as well as street address, since the geocoding process uses zipcode to differentiate the same addresses on the same street. For example, 300 Kennedy Blvd may exist in the cities of Bayonne, Jersey City, and Union City. Find as many toy stores as appropriate, and load the data into your spreadsheet. Once you have completed and saved the spreadsheet in Excel, use “save as” to make a .dbf copy. **Note:** Remember that it is necessary to have the upper left cell in the active workspace selected in order for a dbf file to be properly created from Excel:

When complete, **CLOSE and EXIT Excel.** AV will NOT operate on files that are open in other applications! Use File > Add Data to add your table to AV.
Step 6 – Create an Address Locator
Geocoding in AV9 is slightly different than in AV8. If you are using AV9.0/9.1 or 9.2, please consult “Geocode with AV9” or “Geocode with AV9.2” located in WebCT lessons or at http://faculty.njcu.edu/wmontgomery. Or now (Dec 2008) you can follow below:

Open ArcMap, from the Toolbox, select Geocoding Tools > dbl-click Create Address Locator:

A Create Address Locator window appears:

For Address Style, choose US Streets with Zone (above right); Click OK
For Reference Data, select your line features-roads shapefile (here, somsetroads, which is already in my ToC). Alternatively, you can browse to your folder and select line features-roads.

- Select the Role box to the right of the shapefile name, select Primary table (below)

The Field Map window becomes populated with from the line-features-roads Attribute Table.
NOTE: If you see a red “X” associated with the Field Map window, it is likely that you did not select the “role” correctly.

- You are prompted to save the Address Locator (make sure you save it in your folder!); I named it **somsetroads_AddressLocator** to remind myself that I used that shapefile to create the Address Locator. Press **OK** to complete the saving operation.

A dialog box will appear that confirms successful creation of the Address Locator; press **Close**.

**Step 7- Geocode Addresses**

- Return to ArcMap window, from the Toolbox select **Geocoding Tools > Geocode Addresses**
In the Geocode Addresses window that appears, select the Input Address Table created in Step 5 and the Input Address Locator created in Step 6:

You may see a red “X” appear by the Input Address Fields window (above). This is likely because the Street fields from the Address Locator “Field Name” column is not in “synch” with a field from the Input Address Table (“Alias Name” column). Click on the Alias Name entry that is “None”:

A check of your Input Address Table (below) convinces you that the best “Alias Name” field to “synch” with “Street” in the Field Name column is Street_Add, so select that option.
Once you have made that selection, notice that the red “X” disappears:

- At the bottom of the Geocode Address window, set the path to your folder and confirm (or change) the name of the output feature class (a point shapefile) that will be produced:

- Press OK to start geocoding; a Geocode Address window indicates progress; press Close. The new shapefile of toy store locations should appear in the map window:
Open the Attribute Table for the new shapefile and you can see the results:

<table>
<thead>
<tr>
<th>Status</th>
<th>Matched (or Tied)</th>
<th>Unmatched</th>
</tr>
</thead>
<tbody>
<tr>
<td>M</td>
<td>11</td>
<td>8</td>
</tr>
</tbody>
</table>

Of the 19 addresses I initially tried to geocode, 11 were Matched (or Tied), while 8 were unmatched. The unmatched points show up in the attribute table, but they are **NOT on the MAP**!! There could be any number of reasons why a 100% match was not achieved. Open both the *toy_store.dbf* and the *Attributes of line_features-roads* tables and try to determine **why** your entries did not match.

For example, below are 2 unmatched addresses on US Hwy 206 (315 and 428):

<table>
<thead>
<tr>
<th>Address</th>
<th>Zipcode</th>
</tr>
</thead>
<tbody>
<tr>
<td>315</td>
<td>07921</td>
</tr>
<tr>
<td>428</td>
<td>07921</td>
</tr>
</tbody>
</table>

Immediately, you can see a problem: The only line segments on US 206 that are in zipcode 07921 do NOT have addresses that would bracket number “428” – this would result in an “unmatch.”
However, if I scroll further up in the attribute table, I find that there IS a line segment on US 202/206, in the correct zipcode that DOES bracket number “428” (see below):

In this area of New Jersey, US 202 and 206 are one and the same, so it is highly likely that if I change the target address from 428 US Hwy 206 to 428 US Hwy 202/206, I will get a match.

Some of the questions you want to pursue as you compare the address table to the address locator table (i.e., line feature-roads attribute table) are the following:

- Is the zipcode of the unmatched address consistent with that of the street segment in the reference table?
- Are the streets spelled similarly? (“JFK” does NOT equal “John F. Kennedy” when geocoding)
- Is there an address range on the TIGER attribute table that brackets the address on the toy store table?

Once you have given some thought to the above, move to the step below and try an interactive match. Your efforts should be rewarded with an improved match.

**Step 8 – Perform Manual Geocoding to Improve Results**

From the AV main map, select Tools > Geocoding > Review/Rematch addresses > toy stores:
The Review/Rematch Addresses window that opens (below), confirms what we saw in the attribute table of the geocoded points: 11 out of 19 matched (about 60% success):

You can improve your geocoding by changing some settings and performing the process interactively. First, select **Geocoding Options** (above). In the “Matching Options” portion of the geocoding service window (below), create the following settings, which are less stringent than the default settings:

- **Spelling sensitivity:** 50
- **Minimum candidate score:** 10
- **Minimum match score:** 30
- In the Output Options sections, set the Side Offset to **25 in Feet** (this will place the point on the correct side of the street, and not in the center)
- Click **OK**.
In the Review/Rematch window, select Unmatched Addresses and Match Interactively:

**NOTE:** Refer to the Address Locator table (i.e., your line features-roads attribute table) to evaluate various matching options. You will have to **CLOSE** Interactive Review window and press **DONE** in Review/Rematch to do so (don't worry – your new matches will be automatically saved.).

The **Interactive Review** window appears:

1) Let’s first work on the example I highlighted above, Village Toys, 428 US Hwy 206. When I select this entry, it turns blue. Several potential matches with scores of 51 (not great) appear:

Press the Modify button (arrow above); an Edit Standardization window appears (below left). I modified the StreetName entry from 206 to 202/206 (below, right):

Press **Enter** on your keyboard to “set” this change.
The change is immediately reflected, for the better, with a Match Score of 100 (highlighted below):

Press Match (arrow above) to actually geocode the point, shown by M for Match (below):

2) Let’s look at another example, Boardgames.com at 42 Old Camplain, Zipcode 08844:

Note that the zipcode (red box) in the address locator is different than that in my address table:
From the Interactive Review window; click **Modify**:

An Edit Standardization window opens, with the current address table information (below, left). I changed the Zone entry to 08876 (below right), to match that of the Address Locator table.

Press **Enter** on your computer keyboard to "set" the change. The Interactive Review window now shows an address with a Match Score of 81 (very good):

Press Match (above); the address is **Matched** (see below) and a geocoded point 1s created.
Repeat the process until you have matched as many addresses as possible; 90% or better is excellent. I achieved a 95% match (map shown below):

What Match percentage did you ultimately achieve? Mention this in your exercise writeup.

**Step 9 - Pick a good location for your new “Toys B Me” store**

Now you will analyze your data and pick a location for your new Toys R Us store, based upon your map that shows all toy stores in the county (including the existing Toys R Us stores) and the number of potential child customers in each census tract. You want to site your new Toys R Us store in an area with lots of potential customers.

Create a new point shapefile by using ArcCatalog. The procedure is identical to that you used to map your home in Exr01. Open ArcCatalog, scroll to your folder in the Explorer-style window:
Select File > New > Shapefile;

A Create New Shapefile window opens:

Type a name for the proposed toy store (e.g., Toys_B_Me, above right), make sure it will be a Point. To set the coordinate system, press Edit > Select > Predefined > Geographic > North America > North American Datum 1983.prj.
When the Browse window appears (below left), Press Add, then Apply, then OK.

Click OK when the Create New Shapefile window returns. Drag the new toys_b_me shapefile from ArcCatalog to the top of the ArcMap Table of Contents and drop it.

If you get a warning screen about the coordinate system, press Close:
In the ArcMap ToC, double click on the point representing \textit{toys\_b\_me} (see below) and change its display properties to something more visible (like an orange pentangle):

I identified the intersection of Route 604 & State Road (blue lines below) as prospective for the store. To place a new point on the map, select \textbf{Editor} > \textbf{Start Editing}.
Important! Make sure that Task Window shows “Create New Feature”. In the Target window, select “toys_b_me” (this is the target shapefile in which the new point feature will be created).

Select the small red – yellow pencil (when activated, it will appear to be depressed). Place the mouse at the appropriate place and left-click. A point is created at that spot (see below):
Select **Editor > Save Edits**, then **Stop Editing**. Open the attribute table for the new feature, select **Options > Clear Selection** to remove the current aqua blue color of the point:

The toys_b_me location now shows in its true color (I changed it from orange to yellow):
Step 10 - Create a 2-mile radius buffer around the new store
Select Analysis Tools > Proximity > dbl-click Buffer

A Buffer window appears. For Input Feature, select toys_b_me. An output shapefile is automatically created in your folder. In the distance window, change decimal degrees to Miles, and type 2.0 for the linear unit. Press OK.

Your map returns with a buffer around the proposed location.
Measure the buffer: select **Measuring Tool** > **Select Line** ~ > **Units** ▼ > **Distance** > **Miles**:

Measure from your proposed location out to the edge of the buffer:

In the example above, there is a difference in radius of the buffer: 2.0 miles N-S, but only 1.55 miles E-W. Can you explain why? HINT: the map window is in decimal degrees, and as you move away from the Equator toward the poles, the E-W map length of a degree will shorten.
Step 11 – Intersect Census Tracts with the buffer to determine number of customers
You have already created a column in your census tract data that summed the potential customers (age < 18) for each census tract. By clipping (or intersecting) the census tracts with the 2-mile-radius buffer (like a cookie cutter clips/intersects a sheet of cookie dough), you can determine the number of potential customers living near the proposed store.

From the ArcToolbox window, select Analysis Tools > Overlay > dbl-click Intersect

In the Intersect window that opens, select the input features (census tracts shapefile and buffer); make sure the output is directed to your folder and named appropriately:

Press OK to start the operation. Close the small window when it is completed.
In my case, there are 5 census tracts intersected by the buffer:

Because of naming restrictions (e.g., less than 10 characters for a column), the column headers originally in the census tracts Attribute Table appear to have been changed in the Intersect_buffer table. However, if you line up one table with the other, you can determine what the “under18” column in the census tracts AT corresponds to in the intersect_buffer table:

**Summary:** In my case, there are 815+2335+3012+2742+5 = 8909 children under 18 living in census tracts whose boundaries are within 2 miles of the proposed Toys B Me.
Step 12 - Create a Layout with Geocoded Toy Stores Table
On your map, label all the toy stores with the FID from the Attribute Table (set the Font size in the 10-12 range, and use the same color for the numbers as you did for the points). Use Properties > Fields to keep the following information about the toy stores visible:

Press Apply, OK
Create a layout of your work and include the usual features: Legend, North Arrow, and Scale
From the geocoded toy stores Attribute Table, use **Options > Add Table to Layout**:

Dbl-click on the table when it appears in the layout, then change the Background to a light color:

Click **Apply**, **OK** to set the change.

Use **File > Export** and save your layout as a JPG in your folder.
Your layout should look something like this:

**Toys B Me Proposed Location, Somerset Co, NJ**

<table>
<thead>
<tr>
<th>FID</th>
<th>NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Wishes &amp; Dreams</td>
</tr>
<tr>
<td>1</td>
<td>Right Start</td>
</tr>
<tr>
<td>2</td>
<td>Wizards of the Coast</td>
</tr>
<tr>
<td>3</td>
<td>Tree's A Toys</td>
</tr>
<tr>
<td>4</td>
<td>Build-A Bear Workshop</td>
</tr>
<tr>
<td>5</td>
<td>Toys R Us</td>
</tr>
<tr>
<td>6</td>
<td>Boardgames.com</td>
</tr>
<tr>
<td>7</td>
<td>Tasty Brandy</td>
</tr>
<tr>
<td>8</td>
<td>EB Games</td>
</tr>
<tr>
<td>9</td>
<td>Learning Express</td>
</tr>
<tr>
<td>10</td>
<td>K-B Toys</td>
</tr>
<tr>
<td>11</td>
<td>Village Toys</td>
</tr>
<tr>
<td>12</td>
<td>Novino Corp</td>
</tr>
<tr>
<td>13</td>
<td>Toys with Love</td>
</tr>
<tr>
<td>14</td>
<td>Little Red Cat</td>
</tr>
<tr>
<td>15</td>
<td>Toys R Us</td>
</tr>
<tr>
<td>16</td>
<td>EB Games</td>
</tr>
<tr>
<td>17</td>
<td>Toy Kingdom</td>
</tr>
<tr>
<td>18</td>
<td>J.P. Inc.</td>
</tr>
</tbody>
</table>

**Step 11 - Write up your recommendation**

Write up your procedure and your recommendation for your proposed Toys B Me location in about 250 words; embed your JPG of the layout in your writeup by using Insert > Picture > From File. Make sure you are clear about WHY your location is the BEST location (number of kids under 18 living nearby who are interested in your toys; distance from the competition; nearest major transportation routes, etc.) Also, please indicate what you did and did not like about this exercise. As always, any suggestions for clarification or improvement are also greatly appreciated. So, how do you like GIS for market analysis and site location?